No Auto-Summary in Rip

How to configure No auto summary in RIP?

RIP no auto summary



Configuration in Router 0:- 




Router#sh run
Building configuration...

Current configuration : 618 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 4.4.4.4 255.0.0.0
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.9.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 4.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Configuration in Router 1:-

Router#sh run
Building configuration...

Current configuration : 636 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 3.3.3.3 255.0.0.0
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.11.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 3.0.0.0
network 10.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!

end

Configuration in Router 2:- 

Router#sh run
Building configuration...

Current configuration : 637 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 2.2.2.2 255.0.0.0
!
interface FastEthernet0/0
ip address 11.11.11.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.11.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 2.0.0.0
network 10.0.0.0
network 11.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Configuration in Router 3:- 

Router#sh run
Building configuration...

Current configuration : 636 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.0.0.0
!
interface FastEthernet0/0
ip address 11.11.11.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.9.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
network 11.0.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Before no auto summary 

Router3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Loopback1
R    2.0.0.0/8 [120/1] via 11.11.11.1, 00:00:12, FastEthernet0/0
R    3.0.0.0/8 [120/2] via 10.10.9.1, 00:00:00, FastEthernet0/1
               [120/2] via 11.11.11.1, 00:00:12, FastEthernet0/0          (This is used to Network Load balancing (NLLB))
R    4.0.0.0/8 [120/1] via 10.10.9.1, 00:00:00, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R       10.0.0.0/8 is possibly down, routing via 10.10.9.1, FastEthernet0/1
C       10.10.9.0/24 is directly connected, FastEthernet0/1
R       10.10.10.0/24 [120/1] via 10.10.9.1, 00:00:00, FastEthernet0/1
R       10.10.11.0/24 [120/2] via 10.10.9.1, 00:00:00, FastEthernet0/1
     11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       11.0.0.0/8 is possibly down, routing via 11.11.11.1, FastEthernet0/0
C       11.11.11.0/24 is directly connected, FastEthernet0/0


After assigned no auto summary 

Router3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.9.0 is directly connected, FastEthernet0/1
11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, FastEthernet0/0

Share:

0 comments

Please leave your comments...... Thanks