acl configure in eigrp routing on gns3

How to configure ACL in EIGRP routing in Cisco router step by step?
How to configure multiple ACL in EIGRP routing in Cisco router on GNS?
Configure ACL in EIGRP routing in Cisco router on GNS3
ACL configuration in GNS3




Router 10 Configuration





R10#sh run

Building configuration...

Current configuration : 1341 bytes
!
! Last configuration change at 20:32:54 UTC Wed Aug 24 2016
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R10
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$M2jZ$dQeOhCr7iK.VsUyuaoWyg/
enable password justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 ip address 10.0.0.1 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 99
 network 1.0.0.0 0.0.0.255
 network 1.1.1.0 0.0.0.255
 network 10.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 11 Configuration

R11#  sh run

Building configuration...

Current configuration : 1342 bytes
!
! Last configuration change at 20:34:39 UTC Wed Aug 24 2016
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$IDWr$SChqPe9TDAXCQr1z9ZmLN1
enable password line yogesh
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 30.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 99
 network 3.0.0.0 0.0.0.255
 network 3.3.3.0 0.0.0.255
 network 30.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 3 Configuration

R3#sh run

Building configuration...

Current configuration : 2417 bytes
!
! Last configuration change at 22:34:15 UTC Wed Aug 24 2016
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$t3W6$YIsGKwajsualEs2hWbtjk/
enable password justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface Serial2/0
 ip address 20.0.0.1 255.0.0.0
 serial restart-delay 0
!
interface Serial2/1
 ip address 10.0.0.2 255.0.0.0
 ip access-group 110 in
 serial restart-delay 0
!
interface Serial2/2
 ip address 30.0.0.1 255.0.0.0
 ip access-group 121 in
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet3/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet3/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
!
router eigrp 99
 network 2.2.2.0 0.0.0.255
 network 10.0.0.0
 network 20.0.0.0
 network 30.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 110 deny   icmp host 10.0.0.1 host 40.0.0.1
access-list 110 deny   icmp host 10.0.0.1 host 50.0.0.1
access-list 110 deny   icmp host 10.0.0.1 host 50.0.0.2
access-list 110 deny   icmp host 10.0.0.1 host 6.6.6.6
access-list 110 permit ip any any
access-list 121 deny   icmp host 30.0.0.1 host 9.9.9.9
access-list 121 deny   icmp host 30.0.0.1 host 7.7.7.7
access-list 121 deny   tcp host 30.0.0.2 host 80.0.0.2 eq telnet
access-list 121 deny   tcp host 30.0.0.2 host 60.0.0.2 eq telnet
access-list 121 deny   tcp host 30.0.0.2 host 10.0.0.2 eq telnet
access-list 121 deny   icmp host 30.0.0.2 host 7.7.7.7
access-list 121 deny   icmp host 30.0.0.2 host 9.9.9.9
access-list 121 permit ip any any
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 13 Configuration

R13#sh run

Building configuration...

Current configuration : 1253 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$ObwQ$LhZPvSPc9uUygiOhMcyev0
enable password line yogesh
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 ip address 40.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 99
 network 4.4.4.0 0.0.0.255
 network 40.0.0.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 1 Configuration

R1#sh run

Building configuration...

Current configuration : 1858 bytes
!
! Last configuration change at 22:35:32 UTC Wed Aug 24 2016
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$J4vr$MncxiLRCpJX3f7hRmuPom1
enable password Justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 ip address 20.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 50.0.0.1 255.0.0.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 40.0.0.1 255.0.0.0
 ip access-group 122 in
 serial restart-delay 0
!
interface Serial1/3
 ip address 60.0.0.1 255.0.0.0
 ip access-group 123 in
 serial restart-delay 0
!
!
router eigrp 99
 network 5.5.5.0 0.0.0.255
 network 20.0.0.0
 network 40.0.0.0
 network 50.0.0.0
 network 60.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 122 deny   tcp host 40.0.0.2 host 30.0.0.2 eq telnet
access-list 122 deny   tcp host 40.0.0.2 host 10.0.0.2 eq telnet
access-list 122 deny   tcp host 40.0.0.2 host 70.0.0.2 eq telnet
access-list 122 permit ip any any
access-list 123 deny   tcp host 60.0.0.2 host 40.0.0.2 eq telnet
access-list 123 deny   tcp host 60.0.0.2 host 50.0.0.2 eq telnet
access-list 123 permit ip any any
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password justrelief
 logging synchronous
 login
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password justreleif
 login
line vty 3 4
 login
!
!
end

Router 9 Configuration

R9#sh run

Building configuration...

Current configuration : 1278 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R9
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$zjv6$iA.kyvrwSQ5Y3CRc.IYrL/
enable password justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback2
 ip address 6.6.6.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 ip address 60.0.0.2 255.0.0.0
 serial restart-delay 0
!
!
router eigrp 99
 network 6.0.0.0 0.0.0.255
 network 6.6.6.0 0.0.0.255
 network 60.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 8 Configuration

R8#sh run

Building configuration...

Current configuration : 1275 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R8
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$hZcq$rymFAWQoLr/6cHMeJ3b941
enable password yogesh
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 80.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 99
 network 7.0.0.0 0.0.0.255
 network 7.7.7.0 0.0.0.255
 network 80.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
End

Router 4 Configuration

R4#sh run

Building configuration...

Current configuration : 2237 bytes
!
! Last configuration change at 22:37:22 UTC Wed Aug 24 2016
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$9rnx$K1Or9WBGGg9xxuaM8reLP1
enable password justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 8.8.8.8 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 ip address 50.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 80.0.0.1 255.0.0.0
 ip access-group 124 in
 serial restart-delay 0
!
interface Serial1/2
 ip address 70.0.0.1 255.0.0.0
 ip access-group 125 in
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 ip address 13.0.0.1 255.0.0.0
 speed auto
 duplex auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
!
router eigrp 99
 network 8.8.8.0 0.0.0.255
 network 50.0.0.0
 network 70.0.0.0
 network 80.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 124 deny   icmp host 80.0.0.2 host 1.1.1.1
access-list 124 deny   icmp host 80.0.0.2 host 40.0.0.2
access-list 124 deny   icmp host 80.0.0.2 host 9.9.9.9
access-list 124 permit ip any any
access-list 125 deny   icmp host 70.0.0.2 host 10.0.0.1
access-list 125 deny   icmp host 70.0.0.2 host 80.0.0.1
access-list 125 deny   icmp host 70.0.0.2 host 80.0.0.2
access-list 125 deny   tcp host 70.0.0.2 host 20.0.0.1 eq telnet
access-list 125 deny   tcp host 70.0.0.2 host 20.0.0.2 eq telnet
access-list 125 deny   tcp host 70.0.0.2 host 30.0.0.2 eq telnet
access-list 125 deny   tcp host 70.0.0.2 host 30.0.0.1 eq telnet
access-list 125 permit ip any any
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password justrelief
 login
line vty 3 4
 login
!
!
End

Router 12 Configuration

R12#sh run

Building configuration...

Current configuration : 1280 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$xAl7$72lH3ZBb4dOziQbuYCF.S.
enable password justrelief
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface Loopback1
 ip address 9.9.9.9 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 ip address 70.0.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router eigrp 99
 network 9.0.0.0 0.0.0.255
 network 9.9.9.0 0.0.0.255
 network 70.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 2
 privilege level 15
 password yogesh
 login
line vty 3 4
 login
!
!
end

Share:

0 comments

Please leave your comments...... Thanks